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Basic LWWE Terms

LWWE - the workflow engine that the controls the execution of
workflow tasks

LWWE Components

workflowArchitecture.xml — defines the workflow structure

Contains the workflow name, description, modification information, status
and workflow task structure and information in XML format.

ChildTask — an element in workflowArchitecture.xml
Can be a parent of other tasks or a just a single task.
Tasks have a type and can also contain system executable statements.
Tasks can define dependencies on other tasks.




Files Making up a Workflow

. Architecture definition —
an XML file that contains the overall
structure of workflow tasks and their
dependencies

- Workflow Scripts —
scripts that perform actions for workflow
tasks

. Configuration files (.nar/.ned) —
NED configuration files that contain the
experiment metadata for a workflow (.nar
is a compressed .ned file)




Running a LWWE Workflow
in NED

1.

User submits workflow

NED client sends workflow information to
NED server

Validation is performed by the server
Install directory is created
Configuration files are created

Define the experiment variables {'3- Creates —

Generated according to the

Workflow scripts are installed
Pulled from a source repository 3 Adds
Added to the install directory

NED server starts the workflow
Tasks execute, potentially calling scripts

Monitoring occurs
Users monitors and controls their workflow

configuration settings %‘j — 2
. . Configuration
Added to the install directory Files
2 &
v

NED Client —————————

1. Submits 6. Monitors

B "

5. Starts workflow

GEOSgecm1087

2. Creates

< Iscratch/expDir/GEOSgem1087/

Workflow
Configuration peripty
Files LE

- 4, Calls —p

Source
Repository

Workflow
Scripts

<4— 4. Installs —




Example Workflow
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X NED 1.6 User: mrdamon Mode: USER

File Search Tools Visualization & Analysis Run Views Help
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X NED 1.6 User: mrdamon Mode: USER

alization & Analysis Run Views Help

[ Configuration Tree Configuration | M
V=END_DATE 4] &;_ Narme Description Values
V=]OB_SGMT ormat File format used for output files. 'CFIO' 2 - -
V= NUM SUBMI lename [The output file name. 'tavgl 2d_sh_Nx I[ Configuration | geosges 2181 |
- - template Defines the time stamping template  [%y4%m2%d2_%h2%n2z.nc4' : [geosgcs > 181'
o [ GCS Component: used for output files. : =
¢ CIHISTORY templat{ || |mode Controls whether values are efther | ¢ Prepare the Set-up Environment
o []AGCM instantaneous or time averaged.
& [ COUPLED frequency Frequency of output in HHHHMMSS,  [010000 : [Prepare workflow Setup| Rename the top level of experiment directory and 1
o duration Duration for each file produced 010000 SOURQ|’ |S tup Workflow Envi tIS tup th Wfl ’ ¢
o []GCMTRA| (Y YYMMDD). : etup Workflow Environment] Set up the workflow environmen
o CJMERRA_crio (| [fields Atgbll‘? of °Utpuéff'e'd5» Com{?O”e”tS' Click To Edit... [setup Model Environment] Set up the model environment
- ana allases used ror generating
¢ [v] Seasonal Prepare Installation| Prepare Installation including CvS
o Mtavgl 2d s esour|il ¢ - Handles the main loop tasks
o [JResource Bun Status | / - - - ) . )
L Status | Affects Description JRCES, |Create Experiment Dlrectones| Create the Experiment Directories
o [JMERRA_GRAD :

o [JPOWER
o 3 Visualization setti
V= EMAIL_OPTION

o [ Advanced settings
4 i [»]
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Current File: fhomefworkflow/sharedExperiments/geos5gcm_Fortuna_lwwe.nar Logged Into: localhost:8675[no description]

Configuration in NED

LWWE Workflow monitoring in NED

V=HRST_UK
V= LOCAL_INSTALL_DIR

¢ [J Basic settings

o 3 Run properties

o [ Resolution and layout

o[ Run length
mponents
CJHISTORY templates
o [[JAGCM
o [[]COUPLED
o [[] GCMTRA|
o [JMERRA_CFIO
¢ Seasonal

o [v]tavgl_2d_shs_Nx
o []Resource Bundle
o []MERRA_GRADS
o []POWER

o [ Visualization settings

V= EMAIL_OPTION

o [J Advanced settings

<« Il | >

e

Create RC Templates| Creates the RC Templates
Create Live RCS| Creates the Live RCS

Creates the Link BCS

Get GCM Restarts| Gets the GCM Restarts

? - Handles the run loop tasks

Submit Job| Submits the segment ID

Waits for the segment ID in queue.

uns the model after getting the segment ID
Renames Checkpoint to Restart
Archives the restarts

Moves the History directory or files

Performs the post process

Prepares the next segment

PuUlls back data

COMPLETED UPDATED QUEUED UNKNOWN SUSPENDED RUNNING RESER

INFO
INFO
INFO
INFO
INFO
INFO
INFO
INFO
INFO

Status | geosges_2181-Run Modellog |

of privacy. Unauthorized access or use may subject you to disciplinary
action and criminal prosecution.

This U.S. Government resource is for authorized users only. By accessing
this system you are consenting to complete monitoring with no expectation
of privacy. Unauthorized access or use may subject you to disciplinary
action and criminal prosecution.

This U.S. Goverrment resource is for authorized users only. By accessing
this system you are consenting to complete monitoring with no expectation
of privacy. Unauthorized access or use may subject you to disciplinary
action and criminal prosecution.

Current File: lhome/workflow/sharédExperiments/geosSgcm_Fortuna_Iwwe.nar Logged Into: localhost:8675[no desc




Example Workflow

Configuration in NED

0066 X! NED 1.6 User: mrdamon Mode: USER

File Search Tools Visualization & Analysis Run Views Help

(o] =) =) (@) o] o] @

[ Configuration Tree [ Configuration /
[J BaseWorkflow Name A Description Values
¢ 3 Group numsubmits 3
V= numsubmits modelResolution he spatial resolution of |, o
. the model.
V=modelResolution || |speciesNames Names of species . ;
. ; Click To Edit...
V= speciesNames concentrations
V= archiveSystem archiveSystem Zlame of system to archive e
ata on.
Status |
Status | Affects [ Description

Current File: /home/mrdamon/svn/baseWorkrow[trunk/config/BaseWorkrow.ned Logged Into: localhost:8675[nc

{Value>d</Value>

<DataType >INTEGER< /DataType>

<Widget ctype= :xsi
>

{Variables>
<Name>modelResolution< /Name>
<Description>The spatial resolution of the model. </Descripty
<DesignOnly>false</DesignOnly>
<Enabled>false</Enahled>
<Required>false</Required>
<Value>4x5</Value>
<Value>2x2. 5¢/Value>
<Value>1xl. 25¢/Value>
<DataType>STRING< /DataType>
<Widget type=

>

<Type>COMBOBOX< /Type>
<selected>0</selected>
<editable>false</editable>

<Name>specl e>
<Description>Names of species concentrations</Description>
<DesignOnly>false</DesignOnly>

<Enabled>false</Enabled>

<Required>false</Required>

<Value>C0< /Value>

<¥Value>true</Value>

<Value>N03</Value>

<Value>true</Value>

<Value>03</Value>

<Value>false</Value>

<DataType >STRING< /Datalype>

<Widget :type= 1Xsi= 2

>
<Type>CHECKBOX_LIST< /Type>

</Widget>

</Variables>

<Variables>
<Name >archiveSystem< /Name >
<Description>Name of system to archive data on.</Description>
<DesignOnly>false</DesignOnly>
<Enabled>false</Enabled>
<Required>false</Required>
<Value>discover(1< /Value>
<Value> dali</Value>
<DataType >STRING< /DataType>

Configuration in XML



<?xml version="1.0" encoding="UTF-8" standalone="yes
<Workflowarchitecture >alns="LichtweightWorkflowEn
<Name >BaseWorkf Llow< /Name >
<Description>a simple workflow. </Description>
<Creator></Creator>
<CreationDate>Sept. 5, 2009</CreationDate>
<ModifiedBy>mrdamon< /ModifiedBy>
<ModificationDate></ModificationDate>
<SubmittedBy>mrdamon< /SubmittedBy>
<OverallStatus>Completed< /OverallStatus>
<Version></Version>
<MDSChecksum>< /MDSChecksum>
<ChildTasks>
<Name>baseWorkflow< /Name >
<Description>Basic workflow. </Description>
<Information></Information>
<TaskType>Parent< /TaskType>
<ChildTasks>
<Name>Parent task</Name>

7>

workflowArchitecture.xml

<Description>Parent task for children tasks.</Description>

<Information></Information>
<TaskType>System< /TaskType >
<ExecutableObject>echo "Running paren
<ChildTasks>
<Name>Print Environment< /Name>
<Description>Prints out the environment
<Information></Information>
<TaskType>System< /TaskType>

<ExecutableObject>$NED_WORKING_DIR/bin/ChildTasks. py printOutEnv $NED_WORKING_DIR< /ExecutableObject>

</ChildTasks>

<ChildTasks>
<Name >Empty task< MName>
<Description>A task that doesn't really
<Information></Information>
{TaskType>System< /TaskType>

"¢ /Executablethject>

information< /Descriptions

do anything</Description>

<Executablelbject>$NED_WORKING_DIR/bin/ChildTasks. py emptyTask</Executzblelbject>

</ChildTasks>

</ChildTasks>

<ChildTasks>
<Name>Looping tasks</Name>
<Description>Task that loops</Description>

<Information>Will loop over number of submissions</Information>
¢<IterationLimit>BaseWorkflow. Group. numSubmits</IterationLimit>

<TaskType>Loop< /TaskType >
<ChildTasks>
<Name >Run model< /Name>

<Description>Loads the ENV into workflow</Description>

<TaskType>System< /TaskType>
<ExecutableObject>echo "Running
</ChildTasks>
</ChildTasks>
</ChildTasks>
</Workflowarchitecture>

e1"< fExecutabledbject>




GEOS-5

#!/binfocsh -f

if (! $7CYSROOT |} $TCVS_RSH ) then

exit 1
endif

FREBRRRRRHRHHHHHHHHEH R R R R R R R R R R R R R R R R R R R R
#

Workflow i :

Enter Experiment Specific Run Parameters

HHHHH R R R

if( 81 ==, ) then

else
EAPID = $1
endif

EXPTHP

C SEPTHP[1]
foreach WORD ($EAPTHMP)
if{ $UORD != $EXPDSC ) EXPDSC =

end

IM = $Resolution[1]
M = $Resolutic \[2]
if( $IM == ) then
Nt = 4
NY =8
OT = 1300
SOLAR_DT = 3600
TRRAD_DT = 3600
OCEAN_DT = $IRRAD_DT
endif
if( $IM == ) then
Nt = 4
NY = 16
DT = 1300
SOLAR_DT = 3600
TRRAD_DT = 3600
OCEAN_DT = $IRRAD_DT
endif

if( $IM == ) then

Decompose into

gcm_setup script ~20 GEOS-5 workflow scripts
(Larry’s script) in Python (GEOSgcm/bin)
991 lines



GEOS-5 Workflow

typing at the prompt:

Access the GEOS-5 workflow scripts from mapme by

>> svn checkout file:///home/workflow/WorkflowRepository/ GEOSGCMdemo/tags/release-1.15

Python scripts:

UserUtilities.py
PullBackData.py
SubmitJob.py
WaitinQueue.py
RunLoopRemoteJob.py
RunModel.py
CreateLinkBCs.py
CreateLiveRCS.py
GetGCMRestarts.py
RunLoop.py
CreateExpDirs.py
CreateRCTemplates.py
CleanEnvironment.py
SetupGroupList.py
RemoteSystemTools.py

release-1.15/GEOSgcm/bin contains the core GEOS-5

XMLFileTools.py
UtilSystem.py
Templatedinstantiation.py
SubmitPbsJobAndRecord.py
RunScriptOnRemoteSystem.py
SetUpWorkFlowEnv.py
SetUpMain.py

SetUpEnv.py

PostProcess.py
MainTasks.py
SetUpModelEnv.py
Preparelnstallation.py
RemoteJob.py
GEOS5Main.py



Hands-On Demo




Simple Demo to Modify

- Check out a demo workflow
- Make a simple modification
. Check it back in

- Run it



Requirements for Running e
Workflows

- Required for this demo:

Some experience with CVS or
Subversion

Account on mapme
Member of wf_dev group on mapme



Setup a New Workflow

Log-in to mapme @ NCCS
First time developers must switch to the “wf _dev”
group:
newgrp wf dev
- Create a working directory and cd to it.

Run developer startup script to add command-line
shortcuts:
. /home/workflow/bin/script/wfdev.bash
Execute the following scripts to create a new “demo”
workflow in your working directory

branchWorkflow <username>

checkoutWorkflow <username>



Enhance the Workflow

cd to working directory/<username>/bin
Bring up NED (type “ned”)
Enter in your NCCS User Name, Password, and Passcode and click OK.
Select File -> Open from File. Click OK.
Navigate to working directory/<username>/config
open BaseWorkflow.nar .
Go to File and check Design Mode

Under Configuration Tree select Group. Execute <ctl>right click and navigate to
Add a Variable.

Enter expName in the Information field of the Name property
Fill in the other Information fields as needed. Click OK.

Expand the Variable Group and note the variable named expName listed with
the existing variables.

Under Configuration Tree select Base Workflow.
Execute <ctl>right click then navigate to Edit Workflow Properties.
In the Repository Branch workflow property enter:
/baseWorkflow/branches/<username>



Enhance the Workflow (cont.)

Save and run NED workflow
Select File -> Save.
Select Run -> Submit Workflow

Use the tab labeled baseWorkflow <Unique ID> and watch the
workflow execute.

All tasks should turn yellow (completed) within seconds.

Right click in the white space where the completed LWWE task
tree is showen. Select Expand Tree.

Right click the task called Print Environment under
baseWorkflow <Unique ID>->baseWorkflow->Parent task and
select View Task Log

Check the log information in the lower pane for the expName
variable output.



Tips: Testing Workflows

- Write your workflow with testing in mind:
Be generous with logging
Check for error codes
Use Python’s exception and error handling

. Run the workflow to test it

New workflows get installed and run under:
/scratch/expWorkDir

Check the install directory when problems occur
Use the log files which are viewable from NED

. Test the workflow
As you development make sure to test frequently
Use multiple user accounts to avoid hard-wired solutions



Tips: Troubleshooting T
When a workflow fails...

Determine where the problem is coming from
Files may be missing - did you commit?
User script errors
Check the log file
Edit and re-run the task to see if it passes
Remote script errors - must have a log file
Visit Modeling Guru for questions and answers
NASA website:

SIVO staff regularly monitors Modeling Guru
Knowledge base for Earth System modeling

. Contact SIVO workflow staff for more assistance



Other Resources

. Modeling Guru community

This points to a number of resources for workflow
developers, such as discussion forum that you can
use to post questions to us and others.

User tutorials
Workflow group documentation

- LWWE Documentation
The LWWE software was built by SIVO.



BACKUP SLIDES




Run.script flowchart

»Set expenment directories

*Set mode! run parameters

*Create CAP resource file

*Create History,rc

*Create CAP resource file

*Create CAP resource file

+Link boundary datasets

*Cet restarts and executables

«Perform multiple iterations of medel
*Run the mode!
+Rename checkpoints => restarls for next segment
*Archive history cutput and restaris
»Check for monthly processing
+Update tteration counter

*Re-submit job

GEOS-5 workflow

Submit worflow from NED

mapme

locdlhost | GECEgchD - prepare_anv |- setup_WI_env | hfo: Setup workflow snviroemant

e mm——— = — — SEMup _model Bnv_ befe; Setp model erdrgneeed _ __ ______Y¥______ g
: | main| r load_batch_pams :
: | Ccreate_exp_dirs :
1 create_rc_tempiates |
: create_live_rcs | '
X linkbcs | :
- Getgem_rst_exo ———— afo: Get executable and restarts| :
: - regress_tost :
: - Vtunloop“- - RUNSEGs1 :
| - run_model | Running: ssguent rumber | |
: rename_chk_to_rst :
' archive_rastarts :
: rename_rsi_for_ana :
: move_history | |
: POst_processing - iafo: Submit 3 post-geocessing ob. | |
| gsi_analysis | Iafo: Fun arniysls (If reeded) :
[ rosubmit | oo Pesebrmit to qusse -

T posi process] pull_DAack_datd) infec Prepwe bt for WS

- view_data | Infec To view data run homelworkfiowideviNEDitmp_GEOSGCM _ccrez 2007 S 8 & 38 21 6330view_dats bash/
- clean_env — remove_wi_env | - mfo: |



Steps to integrating the GEOS | ::¢
run scripts

1. GEOS run.script is componentized or decomposed

|dentify portions of the script that are generally
Independent,
Perform a basic task

Pull out that portion into a new script

2. Associate with SMS

New script becomes an SMS task
Task is defined in the definition file
A .sms file is created that invokes the shell script

3. Finally add variables from the workflow
configuration
Most scripts will require user-configurable variables

Simply source the file generated by NED at the top of the
script



Special cases

. Scripts that finish running are considered
“‘complete” by SMS

So submitting a job to a queue requires you to
wait for the job to complete before exiting

. Scripts that get extracted may have variable
dependencies
Shared variables between scripts can be included
. Breaking down tasks changes how jobs enter
the queue
Lots of small jobs vs. single large job



Workflow Config Management I

Proposed Organization
of Workflow's Executable

dirac

Example
. TP T . shared area
Builds and Initialization ‘ ’el e
FI |eS workflow
I I I
geosdas geosgcm sensorWeb gmi
I | I |
merra daedalus coupled
I | |
builds ics bcs builds
GEOSagcm-Eros_7 23 I restarts chembcs bes yuri-beta7p19-momd4p1-t2
GEOSagcm-Eros_7_19 |
|
[ ]
2.0x2.5 0.5x0.5
| I I I I I I
bin config doc etc include lib

|deally GEOS source and workflow’s run scripts

should be kept in sync in the same repository
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Workflow System in NCCS
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